Hunt Chat  

Go Back   Hunt Chat > Tools of the Trade > Modern Muzzleloaders

Thread Tools Display Modes
Old 10-11-2009, 06:33 PM
cfmitch cfmitch is offline
Registered User
Join Date: Jan 2003
Location: Chloe, WV
Posts: 26
Thumbs up CVA Customer Service

We always have something bad to say about someone when things don't go as planned. However, back in March 2009 I had come onto this forum to talk about having problems sighting in my wife's CVA Wolf. As you remember I couldn't get it to hit paper at 25 yds and after reading everyone's post and trying to make those suggestions work out, I finally contacted CVA about my problem. They in turn sent me a new set of sights and even those didn't work. Well, it was nearly three months later when I finally couldn't take it any longer and once again contacted CVA. Thsi time they had me send the gun back in and they returned it proptly with a new barrel and sights. It was already sighted in and hit the bull on the first shot. I can't say anything bad CVA and in fact CVA handled the situation promptly and took care of the problem. Thank you CVA.
Reply With Quote
Old 10-11-2009, 10:53 PM
skeet skeet is offline
Join Date: Jan 2002
Location: Northwest Wyoming
Posts: 4,588
Good for CVA

Always nice to hear good things about a company. I have had some issues with RCBS and Dillon products and boy are they good to work with. Glad ya got that thing shooting.. Now make sure your wife is in the right spot at the right time

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote!"
Benjamin Franklin
Reply With Quote
Old 10-12-2009, 05:08 PM
petey's Avatar
petey petey is offline
Join Date: May 2002
Location: "Pitch Pine", PA
Posts: 65,791
I remember the issue. Glad to hear they fixed the problem. If only the local Jeep dealer would stick behind their factory defect I recently found. Thing's been eating through windsheilds only to find the outer skin on the left support wasn't properly welded from the factory line. Anytime the buggy gets in a torque she'll crack a windsheild from one end to the next. I few quick spot welds from a mig welder by a co-worker, after they wouldn't stick behind their mess up and all is fine now. Oh we had words about it...and they lost a future paying customer b/c of it. Funny part is, you say look here...this is the problem and they say, we don't have any previous recalls on the matter. AH, need to Hijack the thread. Glad to hear the issue is resolved!

Perfect Practice Makes Perfect
Reply With Quote
Old 10-13-2009, 08:42 AM
Nulle Nulle is offline
Join Date: Jun 2002
Location: Belle Fourche, SD
Posts: 4,004
Thats good news and know the problems you went through with it.
Game Bird hatchery/ACO
"It is not the kill anymore it's the Quality of the hunt"
Reply With Quote
Old 11-18-2009, 10:42 PM is offline
Registered User
Join Date: Feb 2001
Location: western pa.
Posts: 1,086
Did they ever explain what the problem was? It would be nice to know in case anyone else has similar I posted in another thread about my tc flint and the use of #9 cleaning solvent mixed with bore butter pre lube patches..found out that was the problem..3 days to solve / figure out.chemical reaction...tack driver at 100yds but just mixing cleaning/shooting lubes couldn't hit a 2' box at 15yds..back to tack driving again...whew...but sure would like to know what they found wrong with your set up and glad they solved issue.
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 03:55 AM.

Powered by vBulletin® Version
Copyright ©2000 - 2013, Jelsoft Enterprises Ltd.